0

I know the title seems like a trivial work, but it got bothering me for two days now. I got a unix machine, on which I have a windows 7 VM.

One of the key of the keyboard stopped working two days ago on the windows VM, and it's the Sharp (Sharp, hash, number-sign) key (while using the UK standard layout). I tried to swap the keyboard with another one, change the layout of both keyboard, it continues not working, even tried to uninstall the driver and reinstall it, nothing worked.

It seems to be windows-wide problem, because the key does not work on the login screen either. Tried to restart in safe mode, the key is not detected anymore, whatever the keyboard or the layout...

The only thing I did two days ago was uninstalling the German language pack, but I did restore windows to that date, but the key is still not functioning, so I don't think it is linked.

0

You wrote the sharp key (I've always called it a [hash key])(https://www.google.co.uk/search?q=hash+key&espv=2&biw=1680&bih=945&source=lnms&tbm=isch&sa=X&ved=0ahUKEwiYtYKpxrPMAhXKdz4KHbiBBfsQ_AUIBigB) but I guess the actual key isn't the problem. It's the fact any key isn't working.

You need a keyboard mapping tool I think.

I assume something is overriding the default key so using something like AutoHotKey to send it should suffice

  • Your comment was why: That is likely something to do with the un-installation of the the German language. As to what exactly caused it, I think that is impossible to tell as we don't have access to the computer, and even if we did it may be hard to find out for sure. – Dave Apr 29 '16 at 9:52
  • Tried AutoHotkey, with a script found somewhere else #InstallKeybdHook, which is supposed to activate the keyboard hook. It seems the key is not even detected anymore, because it doesn't appear in the hook history at all. – Sylordis Apr 29 '16 at 10:02
  • But the hash key remains to work on your LInux machine? It's only faulty in all or just this one VM? – Dave Apr 29 '16 at 12:17
  • Just in the Windows VM – Sylordis Apr 29 '16 at 12:18
0

It seems the problem came from VMware player and not windows as I thought. I restarted the program and now the key works again... Don't know what happened exactly unfortunately.

I checked the ~/.vmware/preferences and /etc/vmware/config files, no rule was added to ignore any key (even if I only saw the possibility to deactivate hotkeys), maybe it was a temporary setting which came, but I don't know how it appeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.