0

I've always been used to pressing the ' and " button twice to get the respective characters. But recently, it changed without my involvement.

Now, when I press the button, I get 2 of them immediately. Aside from being just a pain in the gluteus maximus, it also doesn't allow me to type apostrophe characters.

I don't know when this started, but I believe it had something to do with the last big update, which required rebooting several times. Since this might be an intended feature by Microsoft, I don't know if it's fixable, so any and all answers would be appreciated.

  • Which characters need apostrophes? Or do you mean accents? Check the keyboard layout first. – Sami Kuhmonen Aug 10 '16 at 9:47
  • I mean characters like these --> é. It's not on my keyboard – wessltov Aug 10 '16 at 11:46
  • 1
    Yeah, that's an accent and done with the accent button. Apostrophe is completely different, though many people abuse accents as apostrophes :G ` and ´ vs ' – Sami Kuhmonen Aug 10 '16 at 11:47
  • I hope I'm not expected to call everything by it's correct name, seeing as I'm Dutch. I'd still like to be able to type these characters – wessltov Aug 10 '16 at 11:49
  • No, of course not. Just making sure people know exactly what buttons are being talked about :) – Sami Kuhmonen Aug 10 '16 at 11:50
1

I assume you’re currently using the “US – QWERTY” layout. What you probably want is the US International keyboard. It has all the so-called “dead keys” you want:

  • ' + vowel → vowel with acute accent, e.g., '+e → é
  • ` + vowel → vowel with grave accent, e.g., `+e → è
  • " + vowel → vowel with diaeresis (or umlaut), e.g., "+e → ë
  • ^ + vowel → vowel with circumflex accent, e.g., ^+e → ê
  • ~ + a, n or o → letter with tilde, e.g. ~+n → ñ, ~+o → õ
  • ' + c → ç (Windows)

To enable it, go to Settings → Time & language → Region & language (sidebar). There, select the language (English, Dutch, whatever) you want to modify, click “Options”. Then, under “Keyboards” add the “United Status-International” layout. Then remove the regular US layout.

  • I tried this (changed setting and rebooted), but it didn't work. I actually changed all my languages to the United States-International qwerty, but no luck with this either – wessltov Aug 11 '16 at 2:30
  • Thanks for your answer :D it fixed the quotation mark problem of my keyboard. I had to press twice in a row to get two ' ' (instead of once to get one ') which bothered me many days. Now it's back to normal – Shaohua Li May 3 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.