Environment Windows 7 Cygwin 2.0.2(0.287/5/3)

I have installed autoconf and I have tried...

$ autoconf-2.69
autom4te-2.69: need GNU m4 1.4 or later: /usr/bin/m4

and

$ autoconf-2.13
Autoconf requires GNU m4 1.1 or later

and

$ autoconf
autom4te-2.69: need GNU m4 1.4 or later: /usr/bin/m4

I tried...

$ m4 --version

per the man but it doesn't print anything

 --version
          output version information and exit

This is all super strange and I have confirmed it is installed...

$ apt-cyg install m4
Package m4 is already installed, skipping

How do I get autoconf to work?

$ m4 --version

producing no output is a symptom of missing dll`s or mismatch in their version due to a failed upgrade. I bet you upgraded cygwin with a process still running.

running strace m4 --version will likely confirm the version mismatch and will advise of a missing symbol.

Controlling m4 dependencies we have

$ cygcheck m4
Found: D:\cygwin64\bin\m4.exe
D:\cygwin64\bin\m4.exe
  D:\cygwin64\bin\cygwin1.dll
    C:\windows\system32\KERNEL32.dll
      C:\windows\system32\ntdll.dll
      C:\windows\system32\KERNELBASE.dll
  D:\cygwin64\bin\cygsigsegv-2.dll

Of course you have a cygwin1.dll but it could be a wrong version. For the other dependency

$ cygcheck -f /usr/bin/cygsigsegv-2.dll
libsigsegv2-2.10-2

So you should re-install the packages: cygwin and libsigsegv2

  • Humm can't do a apt-cyg remove cygwin so I am not sure how I would do that. – JGleason Jul 13 at 13:08
  • Do I need to change the mirror to match the installed Cygwin version? – JGleason Jul 13 at 13:10
  • BTW the m4 error is "The procedure entry point __locale_ctype_ptr could not be located in the dynamic link library cygwin1.dll" – JGleason Jul 13 at 13:12
  • @JGleason use cygwin setup to reinstall the two packages – matzeri Jul 13 at 13:27
  • No an option I don't have permissions to reinstall oh well – JGleason Jul 13 at 15:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.