0

I have B450 AORUS M mother board, RTX2070 gpu and ryzen CPU and fully working USB mouse. Ive tried it with other PC. All drivers (bios etc) are up to date and all other stuff working well. But my mouse has some kind of delay. I tried reinstall of drivers and a lot of other tips found on internet, but without any success.

Do you have some suggestions, what can I try to fix this issue? Do you have similar experience?

  • 1
    If the same happens on other computers, it's time to change the mouse. – harrymc Feb 15 at 20:48
  • 2
    When you say "USB mouse," I'm guessing you're speaking of a wired mouse, as opposed to a wireless mouse whose receiver plugs in to a USB port. Have you tried using a different USB port? What's your screen's refresh rate? I hate 30 Hz because it makes the mouse's motion seem really jerky. – BillDOe Feb 15 at 21:10
  • "Ive tried it with other PC" and "and fully working USB mouse" means that mouse works fine with other PCs. Yes I tried all ports without any difference. I have 30Hz but I can only lower it down. And it aslo makes no difference. :( – Daniel Perník Feb 16 at 6:27
0

BillDOe set me up to the right direction with screen refresh rate. Problem was in my HDMI cable - which was capable to do only 30Hz with 4k resolution. I upgraded to DisplayPort 1.3/1.4. Now refresh rate is 60Hz and everything is nice and smooth.

It's really interesting that such a thing can cause "mouse latency" problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.