I am little surprised but google chrome is not saving/showing passwords for certain sites (facebook and google to name few). I remember it was saving this earlier but somehow it is not and I am not sure what has caused this. Any help ? Thanks

EDIT - no sites are in the "do not saved password" list

  • Have the sites disabled form auto-complete? – ale Mar 28 '13 at 13:03

18 Answers 18

up vote 14 down vote accepted

In Chrome's settings (navigate to chrome://settings/ or choose Settings from the... menu?) make sure that you have both "Enable Autofill to fill out web forms in a single click" and "Offer to save passwords I enter on the web" are checked. These are under Passwords and Forms and you'll need to click the link to show advanced settings.

Chrome Passwords and Forms settings

Also check that you are signed into Chrome with the account that you intend on being signed in with and that the sync settings are correct. It could be some weird sync issue where it is saving them until you close and reopen the browser or somesuch.

If all else fails, re-installing Chrome couldn't hurt.

  • 4
    This does not work for all cases. See @hd84335's answer about creating a clean profile. That worked for me. – Kent Johnson Feb 7 '17 at 2:19

Using a clean new profile was the only way that fixed this problem for me:

  1. Go to settings via the following URL:

    chrome://settings
    
  2. Click on the Add person... button to add a new profile

    chrome://settings/createProfile
    
  3. Make this new Chrome profile your default browser to navigate the web

  • 1
    This solved my problem. Thank you. – Elgs Qian Chen Dec 20 '16 at 9:17
  • 1
    If you are using a signed in profile you will need to sign out of it first before creating the new profile. – Joe W Nov 13 '17 at 19:10

I had "Enable Autofill" and "Offer to save passwords" checked. Also, I didn't see any sites in my "Never saved". What fixed it for me was resetting my settings to the default (there is a button on the bottom of the Settings page, in the advanced section).

  • Do a backup before trying this: cp -a $HOME/.config/google-chrome $HOME/.config/google-chrome_OLD. – Pablo Bianchi Nov 16 '17 at 2:15

We have a local server to which I was trying to connect - "https://bowser.gruff.org/admin".

When I first connected, I left off most of the URL, just entering "bowser/admin", which worked (because of sufficiently satisfactory name resolution). However, I got a warning from Chrome (Chromium, actually) that warned that the https site was not secure; I just went into the Advanced settings and told Chrome to ignore the security warning, and was able to log in. But Chrome never prompted me to save my password.

After a couple of days of this, I came and found this site, and after trying other things unsuccessfully, reset my Chrome settings to the default ("Settings" / "Show advanced settings..." / "Reset settings"). Then when I reloaded my page, I again got the security error, and noticed the URL address bar had a red flag with https X'd out, and realized maybe Chrome is not saving passwords on insecure https sites.

So I put in the full URL of "https://bowser.gruff.org/admin", and this time Chrome offered to save my password.

Hopefully this info might help someone.

I had this problem, but I found the solution. With your username and password login to the site, then click the key icon at end of the address bar.

enter image description here

  • 1
    Thanks sir, this doesn't actually explain why the password was not saved (I was connecting to localhost), but is an excellent workaround! – Andrea Casaccia Dec 20 '17 at 9:35
  • Very useful. Thanks. – noumenon Jul 2 at 3:28

Unfortunately I've got the same problem even though I checked remember my password and etc.

But this worked for me so I share it with you, go to: chrome://settings/content

and check the recommended option for cookies(something with "allow to save locally", I don't remember what it exactly was) and click OK. That helped me.

Here are few things you can try doing.

  • Try deleting existing saved passwords. May be Chrome has a limit on the number of saved passwords.

  • Try re-installing the Google Chrome. It might be a bug

  • Updating Google Chrome to most recent version

  • 1
    1) it doesn't seem to be a limit—I just deleted a few dozen passwords, and a site that used to store 3 username/password combos for me only stores 1 now. 2) )One shouldn't need to update Chrome, as it generally updates itself – Auspex Jun 2 '15 at 19:08

https://www.google.com/settings/chrome/sync

Reset Sync

While you are signed out you can save passwords.

  • 3
    Clicking on your link takes me to a Google sign-in page, so the link adds no value. The rest of the answer is cryptic. Can you expand your answer and include the essential information from the link? – fixer1234 Aug 20 '15 at 4:22
  • this is actually what helped me. works if you use google sign in for syncing your profile in the cloud. Signing back in resets the password store and after that it saves just fine. – Ilia Sidorenko Aug 21 '17 at 13:24

None of these suggestions worked for me. I found a helpful link in the Chrome forum that suggests that this happens because your Chrome profile can become corrupted. Here are the steps to take to create a new profile and get your password saving working again:

https://support.google.com/chrome/answer/142059?hl=en

Following these steps also caused my previously saved passwords to come back!

Just make sure that you did not save the password for the same domain with a different port!

  • Chrome is ignoring the port when checking the URL to save or not save.

  • But when fill the fields it cares about the port.

I think this is a Bug in Chrome.

Open Internet Explorer and go to your site. When asked to save the password in IE, say 'Yes'. Now go back to Chrome and go to 'settings', now import saved passwords from IE.

  • 2
    Please do not post all in capitals – Tog Jul 23 '13 at 18:19
  • 1
    Question is about Chrome – vaichidrewar Nov 6 '14 at 7:32
  • @vaichidrewar You didn't read the whole answer. It was about Chrome, but granted, a very round about way of solving the problem. – Paul Phillips May 25 '16 at 9:21

I had the same issue with my site. It appeared that email and password input of sign in form had no name attributes. When I added them and refresh page chrome showed me "save password" popup at the same moment

I went to chrome://settings/content and clicked all cookie and site data. deleted all cookies and chrome started working correctly again.

This is a 'security' feature of Chrome profiles. Chrome does not offer to store passwords for Google (and some other) accounts if you have added your profile to Chrome.

The solution is to:

  1. Remove yourself (your profile) from Chrome
  2. Log in to Gmail, FB etc. Chrome will now offer to store the passwords.
  3. Add your profile back into Chrome.

Solution:

  • Quit Chrome.

  • Go to the directory where Chrome stores its user-specific data, below your user home directory:

    Mac: ~/Library/Application Support/Google/Chrome
    Linux: ~/.config/google-chrome
    Windows: %UserProfile%\AppData\Local\Google\Chrome\User Data

  • From there, go into the directory called Default if you want to fix your main profile, or into Profile 1 or Profile 2, etc., to fix one of your extra profiles.

  • Delete the files "Login Data" and "Login Data-journal".

  • Repeat for other profiles as necessary.

Thanks to http://plasmasturm.org/log/chromepwstore/ for this successful fix.

In addition to allowing Google to remember passwords in the advanced settings, you also have to allow google to set cookies, otherwise google will continue to ask you to login when you exit and go back in.

Besides checking all the recommended chrome settings, i.e. Autofill-ON, Offer to save passwords-ON, as well as setting chrome://flags/#PasswordForceSaving -ON be sure to DELETE (click 'x') the 'Never Saved' list at the bottom of chrome://settings/passwords/. If you have been trying to get a particular site to save your password, and the site tab is still up, delete the tab and restart Chrome and do a fresh browse to that site. Also, I didn't see it documented but if you don't get the 'Save Password' pop-up immediately after all those setting are ON and you have the chrome://flags/#PasswordForceSaving ON then right mouse click (win) after you have entered your password and while the cursor is still in the password box and you should see a pop-up menu with 'Save password' at the top which you should click. I had to do all this a couple of times on some Gov of Canada sites to fix my Not Saving Password problem.

"Open Internet Explorer or Firefox and go to your site. When asked to save the password in IE or Firefox, say 'Yes'. Now go back to Chrome and go to 'settings', now import saved passwords from IE or Firefox" worked for me. Thanks Alex Tvp Storr

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.