Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

The tag has no usage guidance.

0
votes
0answers
17 views

How to run autotools from a nonstandard directory?

I'm trying to build a library on a remote CI server, but I don't have root privileges. The library requires autoconf, automake and libtool packages to be installed. I can't do that with apt-get ...
0
votes
1answer
177 views

Trying to install autoconf dependencies without root permissions

so this is just a part of my grand installation of i3 on a school Linux PC. I'm trying to compile i3 myself and install it in my home directory. I just used my home directory as a prefix for ...
0
votes
0answers
423 views

Error when compiling in Cygwin: “cannot run /bin/sh ./config.sub”

Premise, this is the first time I try to compile anything. I am using the Cygwin (64-bit) terminal on a Windows machine. I am trying to compile some source files that came in a tarball. I navigate ...
0
votes
1answer
93 views

Configure script fails: error: Canonical host info x86_64 unknown cygwin

If this is off-topic, please suggest where I might ask this question. I'm recompiling a library on Cygwin using autotools. I last built it four years ago, and at that time everything worked fine. ...
1
vote
1answer
208 views

Updating autoconf on CentOS

I am working on a CentOS 6.8 system without root privileges. It has autoconf 2.63 installed. I need a more recent version to install something. I downloaded autoconf 2.69 and installed from source (...
0
votes
0answers
362 views

Compiling pinfo on OS X

I would like to install pinfo on my Mac for reading info files, instead of using the bad looking elder brother info. pinfo is not yet provided by Homebrew. Perhaps it will soon, when I will get this ...
9
votes
2answers
20k views

gcc unrecognized command line options '-V' and '-qversion' with autoconf

When compiling with gcc 4.7.2 and autoconf 2.69, I am routinely getting results such as these in configure.log. Example: configure:3091: $? = 0 configure:3080: gcc -V >&5 gcc: error: ...
1
vote
1answer
2k views

How do install POEdit on CentOS 7?

I want to install POEdit on CentOS 7. After running ./configure, I receive a message about several libraries not being installed, such as wxWidgets and Boost. I've installed these libraries and it ...
0
votes
1answer
3k views

Why I obtain this error message when I try to compile cgminer? autoreconf error

I am trying to install Cgminer on my RaspBerry (it use RaspBian that is a Debian minimalistic version) as explained here: https://bitcointalk.org/index.php?topic=494625.0 In particular the ...
0
votes
1answer
795 views

Error compiling gcc on Raspberry Pi (Raspbian): make: *** [bootstrap] error

I'm trying to compile the gcc version 2.95.3 on raspbian, I need it in order to compile the 2.6 kernel. I'm following this tutorial, but when I get to the bootstrapping step, i get make[1]: Entering ...
20
votes
1answer
18k views

How do I resolve an error about AM_PROG_LIBTOOL when building libopus from git?

I've downloaded libopus from git and tried to build it, however I get, Updating build configuration files, please wait.... configure.ac:38: warning: macro 'AM_PROG_LIBTOOL' not found in library ...
1
vote
2answers
4k views

Can't locate Autom4te/ChannelDefs.pm in @INC (when it definitely is there)

I've been running into trouble running make for a build process that I know works on a 32-bit Ubuntu VM. I am running a 64-bit Ubuntu VM, and I have a feeling that the 64-bit may be the problem, but ...
16
votes
5answers
15k views

Autoconf, Libtool, and an undefined AC_PROG_LIBTOOL

I am trying to build a library, and the README instructions are to call configure.ac, then make. Unfortunately, I am running into an error: configure.ac:75 :error: possibly undefined macro: ...
0
votes
1answer
699 views

Why gdb is bind to fixed version of autoconf?

Edit 1: I am trying to build gdb from source. Why can't I use autoconf 2.65 instead of 2.64? It is confusing:( /var/lib/gforge/chroot/home/users/mirror/ins/ins-autoconf/bin/autoreconf -iv ...
1
vote
1answer
2k views

How to update autoconf if I don't have root privilege?

Failed to run autoreconf -iv, for i am using a old autoconf, but i can not update it using system package manager since i am not root so how to update autoconf from 2.59 to 2.64? error message when ...

15 30 50 per page